【需求讨论】bootstrap.sh适配列表issue

需求分析

随着DragonOS的社区的扩大,针对不同平台,甚至是随同一平台的更新, bootstrap.sh 的体验并不十分对齐。是否可以单独开一issue以跟踪不同平台bootstrap适配程度,并引导相关问题在该issue处提出?

比如我今天帮同学安装DragonOS环境时就遇到,pip3并不随python3包的安装而安装的问题:

平台:虚拟机 Ubuntu Server 22.04 全新安装

按道理bootstrap就应该像拉稀一样流畅装好才对,毕竟是标准环境;但还是出现了这样的问题。虽然是很细小的错误,终究还是会影响体验,也会让人一头雾水。

2 个赞

当然这个需要人来维护,不过我很乐意做这个维护工作倒是。

感觉可以添加一个回归测试,集成到自动化流程(github workflow)

1 个赞